[FusionInsight] 关于linux6.4下Storm的Python版本报错的处理

Linux 6.4下同个/bin/python,root默认python是2.6.6,不过应用用户默认python是2.6.2

Storm 0.9恰好需要python2.6.6或以上,使用FusionInsight时由于读取默认python会报错python版本问题。

解决措施:

#Step1 打开Storm客户端打包脚本
$ vi /Storm客户端/Streaming/streaming-0.10.0/bin/storm

经测试可用,已跟华为提建议优化自定义python版本,避免此问题

 

 

分类上一篇:     分类下一篇:

Leave a Reply